summaryrefslogtreecommitdiffstats
path: root/security/ossec-hids-local/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/ossec-hids-local/Makefile')
-rw-r--r--security/ossec-hids-local/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/security/ossec-hids-local/Makefile b/security/ossec-hids-local/Makefile
index 2c98523..f17eee2 100644
--- a/security/ossec-hids-local/Makefile
+++ b/security/ossec-hids-local/Makefile
@@ -24,7 +24,7 @@ CONFLICTS_INSTALL= ossec-hids-client-* \
ossec-hids-local-*
.endif
-LIB_DEPENDS= libpcre2-8.so:devel/pcre2
+LIB_DEPENDS= libpcre2-8.so:devel/pcre2 libevent.so:devel/libevent
.if ${OSSEC_TYPE} != agent
RUN_DEPENDS= expect:lang/expect
.endif
@@ -129,7 +129,12 @@ FIREWALL_DROP_BIN= ${OSSEC_HOME}/active-response/bin/firewall-drop.sh
IPFILTER_BIN= ${OSSEC_HOME}/active-response/bin/ipfilter.sh
RESTART_OSSEC_BIN= ${OSSEC_HOME}/active-response/bin/restart-ossec.sh
SHARED_DIR= ${OSSEC_HOME}/etc/shared
-INTERNAL_OPTS_CONF= ${OSSEC_HOME}/etc/local_internal_options.conf
+
+SAMPLE_FILES= ${OSSEC_HOME}/etc/local_internal_options.conf \
+ ${OSSEC_HOME}/active-response/bin/cloudflare-ban.sh \
+ ${OSSEC_HOME}/active-response/bin/ossec-pagerduty.sh \
+ ${OSSEC_HOME}/active-response/bin/ossec-slack.sh \
+ ${OSSEC_HOME}/active-response/bin/ossec-tweeter.sh
.if empty(USER)
USER=$$(${ID} -un)
@@ -181,6 +186,9 @@ INOTIFY_CFLAGS= $$(${PKG_CONFIG} --cflags libinotify)
INOTIFY_LDFLAGS=$$(${PKG_CONFIG} --libs libinotify)
OSSEC_ARGS+= TARGET=${OSSEC_TYPE} PCRE2_SYSTEM=yes INSTALL_LOCALTIME=no INSTALL_RESOLVCONF=no
+.if defined(OSSEC_MAX_AGENTS)
+OSSEC_ARGS+= MAXAGENTS=${OSSEC_MAX_AGENTS}
+.endif
.if !defined(MAINTAINER_MODE)
OSSEC_ARGS+= INSTALL_CMD=install
.endif
@@ -206,7 +214,9 @@ do-install:
@cd ${WRKSRC}/src; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${INSTALL_ARGS} install
post-install:
- @${MV} -f ${STAGEDIR}${INTERNAL_OPTS_CONF} ${STAGEDIR}${INTERNAL_OPTS_CONF}.sample
+.for file_path in ${SAMPLE_FILES}
+ @${MV} -f ${STAGEDIR}${file_path} ${STAGEDIR}${file_path}.sample
+.endfor
@${MV} -f ${STAGEDIR}${FIREWALL_DROP_BIN} ${STAGEDIR}${IPFILTER_BIN}
@${CP} ${WRKDIR}/restart-ossec.sh ${STAGEDIR}${RESTART_OSSEC_BIN}
@${CHMOD} 550 ${STAGEDIR}${RESTART_OSSEC_BIN}