summaryrefslogtreecommitdiffstats
path: root/security/ossec-hids-local/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/ossec-hids-local/Makefile')
-rw-r--r--security/ossec-hids-local/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/security/ossec-hids-local/Makefile b/security/ossec-hids-local/Makefile
index e6553b2..4b189dc 100644
--- a/security/ossec-hids-local/Makefile
+++ b/security/ossec-hids-local/Makefile
@@ -1,4 +1,4 @@
-# $FreeBSD$
+# $FreeBSD: head/security/ossec-hids-local/Makefile 484537 2018-11-09 18:52:21Z swills $
PORTNAME= ossec-hids
PORTVERSION= 3.1.0
@@ -12,6 +12,8 @@ COMMENT= Security tool to monitor and check logs and intrusions
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
+USES= gmake readline ssl
+
OSSEC_TYPE?= local
.if ${OSSEC_TYPE} == local
@@ -37,7 +39,6 @@ INOTIFY_LIB_DEPENDS= libinotify.so:devel/libinotify
PRELUDE_LIB_DEPENDS= libprelude.so:security/libprelude
ZEROMQ_LIB_DEPENDS= libczmq.so:net/czmq
-USES= gmake readline ssl
MYSQL_USE= mysql
PGSQL_USES= pgsql
@@ -204,12 +205,12 @@ do-install:
post-install:
@${MV} -f ${STAGEDIR}${INTERNAL_OPTS_CONF} ${STAGEDIR}${INTERNAL_OPTS_CONF}.sample
@${MV} -f ${STAGEDIR}${FIREWALL_DROP_BIN} ${STAGEDIR}${IPFILTER_BIN}
- @${CP} -f ${WRKDIR}/restart-ossec.sh ${STAGEDIR}${RESTART_OSSEC_BIN}
+ @${CP} ${WRKDIR}/restart-ossec.sh ${STAGEDIR}${RESTART_OSSEC_BIN}
@${CHMOD} 550 ${STAGEDIR}${RESTART_OSSEC_BIN}
.if defined(MAINTAINER_MODE)
@${CHOWN} ${USER}:${OSSEC_GROUP} ${STAGEDIR}${RESTART_OSSEC_BIN}
.endif
-
+
.if ${OSSEC_TYPE} == agent
.if defined(MAINTAINER_MODE)
@for file_name in $$(find "${STAGEDIR}${SHARED_DIR}" -type f); do ${CHMOD} 0644 $${file_name}; ${CHOWN} ${OSSEC_USER}:${OSSEC_GROUP} $${file_name}; done