summaryrefslogtreecommitdiffstats
path: root/security/ossec-hids-local/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/ossec-hids-local/Makefile')
-rw-r--r--security/ossec-hids-local/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/security/ossec-hids-local/Makefile b/security/ossec-hids-local/Makefile
index b14b845..54433b3 100644
--- a/security/ossec-hids-local/Makefile
+++ b/security/ossec-hids-local/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD: head/security/ossec-hids-local/Makefile 490211 2019-01-13 20:58:36Z adamw $
PORTNAME= ossec-hids
-PORTVERSION= 3.2.0
-PORTREVISION=
+PORTVERSION= 3.3.0
+PORTREVISION= 0
CATEGORIES= security
PKGNAMESUFFIX= -${OSSEC_TYPE}
@@ -30,6 +30,7 @@ CONFLICTS_INSTALL= ossec-hids-client-* \
ossec-hids-local-*
.endif
+LIB_DEPENDS= libpcre2-8.so:devel/pcre2
.if ${OSSEC_TYPE} != agent
RUN_DEPENDS= expect:lang/expect
.endif
@@ -182,7 +183,7 @@ CFLAGS+= -I${LOCALBASE}/include
INOTIFY_CFLAGS= $$(${PKG_CONFIG} --cflags libinotify)
INOTIFY_LDFLAGS=$$(${PKG_CONFIG} --libs libinotify)
-OSSEC_ARGS+= TARGET=${OSSEC_TYPE} INSTALL_LOCALTIME=no
+OSSEC_ARGS+= TARGET=${OSSEC_TYPE} PCRE2_SYSTEM=yes INSTALL_LOCALTIME=no INSTALL_RESOLVCONF=no
.if !defined(MAINTAINER_MODE)
OSSEC_ARGS+= INSTALL_CMD=install
.endif