summaryrefslogtreecommitdiffstats
path: root/security/ossec-hids-local/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/ossec-hids-local/Makefile')
-rw-r--r--security/ossec-hids-local/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/security/ossec-hids-local/Makefile b/security/ossec-hids-local/Makefile
index 8a9e538..196b503 100644
--- a/security/ossec-hids-local/Makefile
+++ b/security/ossec-hids-local/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ossec-hids
PORTVERSION= 3.1.0
-PORTREVISION=
+PORTREVISION= 1
CATEGORIES= security
PKGNAMESUFFIX= -${OSSEC_TYPE}
@@ -88,7 +88,6 @@ ZEROMQ_VARS= OSSEC_ARGS+=USE_ZEROMQ=yes
MYSQL_VARS= OSSEC_ARGS+=DATABASE=mysql PKGMSG_FILES+=message-database DB_TYPE=mysql DB_SCHEMA=mysql.schema
PGSQL_VARS= OSSEC_ARGS+=DATABASE=pgsql PKGMSG_FILES+=message-database DB_TYPE=postgresql DB_SCHEMA=postgresql.schema
-OSSEC_ARGS+= TARGET=${OSSEC_TYPE}
.if ${OSSEC_TYPE} == agent
STRIP_FILES= agent-auth \
manage_agents \
@@ -184,6 +183,10 @@ PKGMSG_FILES= message-header
CFLAGS+= -I${LOCALBASE}/include
+OSSEC_ARGS+= TARGET=${OSSEC_TYPE} INSTALL_LOCALTIME=no
+.if !defined(MAINTAINER_MODE)
+OSSEC_ARGS+= INSTALL_CMD=install
+.endif
BUILD_ARGS+= ${MAKE_ARGS} ${OSSEC_ARGS} PREFIX=${OSSEC_HOME}
INSTALL_ARGS+= ${USER_ARGS} ${OSSEC_ARGS} PREFIX=${STAGEDIR}${OSSEC_HOME}