summaryrefslogtreecommitdiffstats
path: root/security/ossec-hids-local-config/opt-rules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'security/ossec-hids-local-config/opt-rules.mk')
-rw-r--r--security/ossec-hids-local-config/opt-rules.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/security/ossec-hids-local-config/opt-rules.mk b/security/ossec-hids-local-config/opt-rules.mk
new file mode 100644
index 0000000..c8db7a2
--- /dev/null
+++ b/security/ossec-hids-local-config/opt-rules.mk
@@ -0,0 +1,27 @@
+RULES_MANAGED_CONF= 100.rules.conf
+RULES_LOCAL_CONF= 500.rules.local.conf
+
+RULES_DESC= Alerting Rules
+
+RULES_FILES= config cmdout
+
+# Default rules
+RULES_DEFAULT_OPTION= DEFAULT_R
+RULES_DEFAULT_DESC= Default rules provided by OSSEC
+RULES_DEFAULT_DEFINE= server local
+RULES_DEFAULT_DEFAULT= server local
+RULES_OPTIONS+= RULES_DEFAULT
+
+# Config rules
+RULES_CONFIG_OPTION= CONFIG_R
+RULES_CONFIG_DESC= Alert changes of the OSSEC main configuration files
+RULES_CONFIG_DEFINE= server local
+RULES_CONFIG_DEFAULT= server local
+RULES_OPTIONS+= RULES_CONFIG
+
+# Command output rules
+RULES_CMDOUT_OPTION= CMDOUT_R
+RULES_CMDOUT_DESC= Alert changes of output of the monitored commands
+RULES_CMDOUT_DEFINE= server local
+RULES_CMDOUT_DEFAULT= server local
+RULES_OPTIONS+= RULES_CMDOUT