summaryrefslogtreecommitdiffstats
path: root/security/ossec-hids-local-config/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/ossec-hids-local-config/Makefile')
-rw-r--r--security/ossec-hids-local-config/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/security/ossec-hids-local-config/Makefile b/security/ossec-hids-local-config/Makefile
index 9ca25d4..c8e795c 100644
--- a/security/ossec-hids-local-config/Makefile
+++ b/security/ossec-hids-local-config/Makefile
@@ -157,9 +157,15 @@ ${conf_group}_PUSHED_OPTIONS=
. for option in ${${conf_group}_OPTIONS}
. if ${${option}_DEFINE:M${OSSEC_TYPE}}
${conf_group}_INSTANCE_OPTIONS+= ${option}
+${conf_group}_ALL_OPTIONS+= ${option}
. endif
-. if ${OSSEC_TYPE} == server && ${${option}_DEFINE:Mpushed}
+. if ${${option}_DEFINE:Mpushed}
+. if ${OSSEC_TYPE} == server
${conf_group}_PUSHED_OPTIONS+= ${option}
+. endif
+. if !${${conf_group}_ALL_OPTIONS:M${option}}
+${conf_group}_ALL_OPTIONS+= ${option}
+. endif
. endif
. endfor
.endfor
@@ -177,7 +183,7 @@ CLIENT_PROFILES:= ${CLIENT_PROFILES}, ${${conf_group}_PROFILE}
. endif
SUB_LIST+= ${conf_group}_PROFILE=${${conf_group}_PROFILE}
. endif
-. for option in ${${conf_group}_INSTANCE_OPTIONS}
+. for option in ${${conf_group}_ALL_OPTIONS}
. if !empty(${option}_PROFILE)
. if ${OSSEC_TYPE} == agent
. if empty(CLIENT_PROFILES)
@@ -196,11 +202,11 @@ SUB_LIST+= CLIENT_PROFILES="${CLIENT_PROFILES}"
############################################################
.for conf_group in ${CONF_GROUPS}
-. for option in ${${conf_group}_INSTANCE_OPTIONS}
+. for option in ${${conf_group}_ALL_OPTIONS}
. if !defined(${option}_TEMPLATE)
${option}_TEMPLATE= template-${option:tl:S/_/-/g}.xml
. endif
-. if !empty(${option}_TEMPLATE)
+. if !empty(${option}_TEMPLATE) && !${SUB_FILES:M${${option}_TEMPLATE}}
SUB_FILES+= ${${option}_TEMPLATE}
. endif
. endfor