summaryrefslogtreecommitdiffstats
path: root/security/ossec-hids-local
diff options
context:
space:
mode:
authorDominik Lisiak <dominik.lisiak@bemsoft.pl>2021-06-27 21:39:03 +0200
committerDominik Lisiak <dominik.lisiak@bemsoft.pl>2021-06-27 21:39:03 +0200
commit8bedf9eeeb5079ef6bef01d13032a327fd941a05 (patch)
tree3c0e491152b799dd392696c0485ba1f790007e00 /security/ossec-hids-local
parentAdded official patches for 3.6.0_1 (diff)
downloadossec-8bedf9eeeb5079ef6bef01d13032a327fd941a05.tar.xz
Replaced sed with esed to be compatible with FreeBSD 13.0.3.6.0_2
Diffstat (limited to 'security/ossec-hids-local')
-rw-r--r--security/ossec-hids-local/Makefile2
-rw-r--r--security/ossec-hids-local/files/ossec-hids.in2
-rw-r--r--security/ossec-hids-local/scripts/plist.sh4
3 files changed, 3 insertions, 5 deletions
diff --git a/security/ossec-hids-local/Makefile b/security/ossec-hids-local/Makefile
index b54dfb4..c800cea 100644
--- a/security/ossec-hids-local/Makefile
+++ b/security/ossec-hids-local/Makefile
@@ -1,5 +1,3 @@
-# $FreeBSD: head/security/ossec-hids-local/Makefile 556647 2020-11-30 15:16:43Z linimon $
-
PKGNAMESUFFIX?= -${OSSEC_TYPE}
COMMENT?= Security tool to monitor and check logs and intrusions - local (standalone) installation
OSSEC_TYPE?= local
diff --git a/security/ossec-hids-local/files/ossec-hids.in b/security/ossec-hids-local/files/ossec-hids.in
index 6c580f2..8778376 100644
--- a/security/ossec-hids-local/files/ossec-hids.in
+++ b/security/ossec-hids-local/files/ossec-hids.in
@@ -486,7 +486,7 @@ ossec_hids_fetch_config() {
echo "${ossec_rc_path} reset_counter"
echo "${ossec_rc_path} fetch_config"
echo
- echo "If this does't help, you need to reset counter on the server."
+ echo "If this doesn't help, you need to reset counter on the server."
echo "If the server runs FreeBSD port of OSSEC, run:"
echo "On the agent:"
echo "${ossec_rc_path} reset_counter"
diff --git a/security/ossec-hids-local/scripts/plist.sh b/security/ossec-hids-local/scripts/plist.sh
index b1915c4..07fbcd5 100644
--- a/security/ossec-hids-local/scripts/plist.sh
+++ b/security/ossec-hids-local/scripts/plist.sh
@@ -61,10 +61,10 @@ while read line; do
path=""
case ${line} in
"@dir %%OSSEC_HOME%%"*)
- path=`echo "${line}" | sed -e "s|@dir %%OSSEC_HOME%%||g"`
+ path=`echo "${line}" | sed -E 's|@dir %%OSSEC_HOME%%||g'`
;;
"%%OSSEC_HOME%%"*)
- path=`echo "${line}" | sed -e "s|%%OSSEC_HOME%%||g"`
+ path=`echo "${line}" | sed -E 's|%%OSSEC_HOME%%||g'`
;;
"%%"*)
unchanged_lines="${unchanged_lines}${NL}${line}"