summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominik Lisiak <dominik.lisiak@bemsoft.pl>2020-12-07 12:07:48 +0100
committerDominik Lisiak <dominik.lisiak@bemsoft.pl>2020-12-07 12:07:48 +0100
commit6d5bb68c6800fc0a0cf9a01c2be4272a33276fe4 (patch)
tree3b78a4c71904a059bbafbed9fb6348366b2af649
parentAdded committer lines. (diff)
downloadossec-6d5bb68c6800fc0a0cf9a01c2be4272a33276fe4.tar.xz
Added official patches for 3.6.0_13.6.0_1
-rw-r--r--security/ossec-hids-local/Makefile5
-rw-r--r--security/ossec-hids-local/files/patch-src_addagent_main.c18
-rw-r--r--security/ossec-hids-local/files/patch-src_addagent_manage__agents.h8
-rw-r--r--security/ossec-hids-local/files/patch-src_client-agent_agentd.c19
-rw-r--r--security/ossec-hids-local/files/patch-src_client-agent_agentd.h11
-rw-r--r--security/ossec-hids-local/files/patch-src_client-agent_config.c12
-rw-r--r--security/ossec-hids-local/files/patch-src_os__net_os__net.c10
-rw-r--r--security/ossec-hids/version.mk2
8 files changed, 83 insertions, 2 deletions
diff --git a/security/ossec-hids-local/Makefile b/security/ossec-hids-local/Makefile
index 891712c..b54dfb4 100644
--- a/security/ossec-hids-local/Makefile
+++ b/security/ossec-hids-local/Makefile
@@ -1,4 +1,4 @@
-# $FreeBSD: head/security/ossec-hids-local/Makefile 528054 2020-03-08 16:35:08Z tcberner $
+# $FreeBSD: head/security/ossec-hids-local/Makefile 556647 2020-11-30 15:16:43Z linimon $
PKGNAMESUFFIX?= -${OSSEC_TYPE}
COMMENT?= Security tool to monitor and check logs and intrusions - local (standalone) installation
@@ -8,6 +8,9 @@ OSSEC_TYPE?= local
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_aarch64= fails to compile: rootcheck/os_string.c:186:20: use of undeclared identifier '__LDPGSZ'
+BROKEN_riscv64= fails to compile: rootcheck/os_string.c:186:20: use of undeclared identifier '__LDPGSZ'
+
USES= compiler gmake ssl
.if ${OSSEC_TYPE} == local
diff --git a/security/ossec-hids-local/files/patch-src_addagent_main.c b/security/ossec-hids-local/files/patch-src_addagent_main.c
new file mode 100644
index 0000000..130872b
--- /dev/null
+++ b/security/ossec-hids-local/files/patch-src_addagent_main.c
@@ -0,0 +1,18 @@
+--- src/addagent/main.c.orig 2020-02-14 19:46:22 UTC
++++ src/addagent/main.c
+@@ -17,6 +17,7 @@ static void print_banner(void);
+ static void manage_shutdown(int sig) __attribute__((noreturn));
+ #endif
+
++int willchroot;
+
+ #if defined(__MINGW32__)
+ static int setenv(const char *name, const char *val, __attribute__((unused)) int overwrite)
+@@ -104,7 +105,6 @@ int main(int argc, char **argv)
+ int ret;
+ #endif
+
+- extern int willchroot;
+ willchroot = 1;
+
+ /* Set the name */
diff --git a/security/ossec-hids-local/files/patch-src_addagent_manage__agents.h b/security/ossec-hids-local/files/patch-src_addagent_manage__agents.h
new file mode 100644
index 0000000..1e1f32d
--- /dev/null
+++ b/security/ossec-hids-local/files/patch-src_addagent_manage__agents.h
@@ -0,0 +1,8 @@
+--- src/addagent/manage_agents.h.orig 2020-02-14 19:46:22 UTC
++++ src/addagent/manage_agents.h
+@@ -147,4 +147,4 @@ extern fpos_t fp_pos;
+ #define GMF_UNKN_ERROR ARGV0 ": Could not run GetModuleFileName which returned (%ld).\n"
+
+
+-int willchroot;
++extern int willchroot;
diff --git a/security/ossec-hids-local/files/patch-src_client-agent_agentd.c b/security/ossec-hids-local/files/patch-src_client-agent_agentd.c
new file mode 100644
index 0000000..ab65307
--- /dev/null
+++ b/security/ossec-hids-local/files/patch-src_client-agent_agentd.c
@@ -0,0 +1,19 @@
+--- src/client-agent/agentd.c.orig 2020-02-14 19:46:22 UTC
++++ src/client-agent/agentd.c
+@@ -15,6 +15,8 @@
+ #include "os_dns/os_dns.h"
+ #endif //WIN32
+
++struct imsgbuf server_ibuf;
++
+ /* Start the agent daemon */
+ void AgentdStart(const char *dir, int uid, int gid, const char *user, const char *group)
+ {
+@@ -39,7 +41,6 @@ void AgentdStart(const char *dir, int uid, int gid, co
+ merror("starting imsg stuff");
+ /* Prepare for os_dns */
+ struct imsgbuf osdns_ibuf;
+- extern struct imsgbuf server_ibuf;
+ //struct imsgbuf osdns_ibuf;
+ int imsg_fds[2];
+ merror("Creating socketpair()");
diff --git a/security/ossec-hids-local/files/patch-src_client-agent_agentd.h b/security/ossec-hids-local/files/patch-src_client-agent_agentd.h
new file mode 100644
index 0000000..6184697
--- /dev/null
+++ b/security/ossec-hids-local/files/patch-src_client-agent_agentd.h
@@ -0,0 +1,11 @@
+--- src/client-agent/agentd.h.orig 2020-02-14 19:46:22 UTC
++++ src/client-agent/agentd.h
+@@ -83,7 +83,7 @@ extern int run_foreground;
+ extern keystore keys;
+ extern agent *agt;
+ #ifndef WIN32
+-struct imsgbuf server_ibuf;
++extern struct imsgbuf server_ibuf;
+ #endif //WIN32
+
+ #endif /* __AGENTD_H */
diff --git a/security/ossec-hids-local/files/patch-src_client-agent_config.c b/security/ossec-hids-local/files/patch-src_client-agent_config.c
new file mode 100644
index 0000000..74765c6
--- /dev/null
+++ b/security/ossec-hids-local/files/patch-src_client-agent_config.c
@@ -0,0 +1,12 @@
+--- src/client-agent/config.c.orig 2020-02-14 19:46:22 UTC
++++ src/client-agent/config.c
+@@ -17,8 +17,8 @@
+ time_t available_server;
+ int run_foreground;
+ keystore keys;
+-agent *agt;
+
++extern agent *agt;
+
+ /* Read the config file (for the remote client) */
+ int ClientConf(const char *cfgfile)
diff --git a/security/ossec-hids-local/files/patch-src_os__net_os__net.c b/security/ossec-hids-local/files/patch-src_os__net_os__net.c
new file mode 100644
index 0000000..0cc1696
--- /dev/null
+++ b/security/ossec-hids-local/files/patch-src_os__net_os__net.c
@@ -0,0 +1,10 @@
+--- src/os_net/os_net.c.orig 2020-02-14 19:46:22 UTC
++++ src/os_net/os_net.c
+@@ -14,6 +14,7 @@
+ #include <errno.h>
+ #include "shared.h"
+ #include "os_net.h"
++
+ agent *agt;
+
+ /* Prototypes */
diff --git a/security/ossec-hids/version.mk b/security/ossec-hids/version.mk
index 7d5b06d..5d3591f 100644
--- a/security/ossec-hids/version.mk
+++ b/security/ossec-hids/version.mk
@@ -1,6 +1,6 @@
PORTNAME= ossec-hids
PORTVERSION= 3.6.0
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= security
MAINTAINER= dominik.lisiak@bemsoft.pl