summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominik Lisiak <dominik.lisiak@bemsoft.pl>2019-08-25 19:37:39 +0200
committerDominik Lisiak <dominik.lisiak@bemsoft.pl>2019-08-25 19:37:39 +0200
commit5c868b7aea8d57dbe119011093ac96677e2c3b03 (patch)
treeff23bf653f4c7f83fa0601864f3eb1b3c770cb62
parentPrepare for powerpc-on-clang by deleting hard-coded tests for architecture (diff)
downloadossec-5c868b7aea8d57dbe119011093ac96677e2c3b03.tar.xz
Moved basic port variables to ossec-hids/version.mk.
-rw-r--r--security/ossec-hids-agent/Makefile1
-rw-r--r--security/ossec-hids-local-config/Makefile15
-rw-r--r--security/ossec-hids-local/Makefile14
-rw-r--r--security/ossec-hids-server/Makefile1
-rw-r--r--security/ossec-hids/Makefile10
-rw-r--r--security/ossec-hids/version.mk9
6 files changed, 20 insertions, 30 deletions
diff --git a/security/ossec-hids-agent/Makefile b/security/ossec-hids-agent/Makefile
index 60fc031..158ce0c 100644
--- a/security/ossec-hids-agent/Makefile
+++ b/security/ossec-hids-agent/Makefile
@@ -1,5 +1,6 @@
# $FreeBSD: head/security/ossec-hids-agent/Makefile 484537 2018-11-09 18:52:21Z swills $
+COMMENT= Security tool to monitor and check logs and intrusions - agent installation
OSSEC_TYPE= agent
MASTERDIR= ${.CURDIR}/../ossec-hids-local
diff --git a/security/ossec-hids-local-config/Makefile b/security/ossec-hids-local-config/Makefile
index 61a66b8..df8fc16 100644
--- a/security/ossec-hids-local-config/Makefile
+++ b/security/ossec-hids-local-config/Makefile
@@ -1,18 +1,11 @@
# $FreeBSD: head/security/ossec-hids-local-config/Makefile 503254 2019-06-01 19:39:09Z pi $
-PORTNAME= ossec-hids
-PORTVERSION= 3.3.0
-PORTREVISION= 0
-CATEGORIES= security
-PKGNAMESUFFIX= -${OSSEC_TYPE}-config
-
-MAINTAINER= dominik.lisiak@bemsoft.pl
-COMMENT= Configuration manager for ossec-hids
-
-LICENSE= GPLv2
-
+PKGNAMESUFFIX?= -${OSSEC_TYPE}-config
+COMMENT?= Configuration manager for ossec-hids-${OSSEC_TYPE}
OSSEC_TYPE?= local
+.include "${.CURDIR}/../ossec-hids/version.mk"
+
MASTERDIR?= ${.CURDIR}
.if ${OSSEC_TYPE} == local
diff --git a/security/ossec-hids-local/Makefile b/security/ossec-hids-local/Makefile
index 0e57d34..2c98523 100644
--- a/security/ossec-hids-local/Makefile
+++ b/security/ossec-hids-local/Makefile
@@ -1,21 +1,15 @@
# $FreeBSD: head/security/ossec-hids-local/Makefile 507308 2019-07-25 02:33:12Z linimon $
-PORTNAME= ossec-hids
-PORTVERSION= 3.3.0
-PORTREVISION= 0
-CATEGORIES= security
-PKGNAMESUFFIX= -${OSSEC_TYPE}
+PKGNAMESUFFIX?= -${OSSEC_TYPE}
+COMMENT?= Security tool to monitor and check logs and intrusions - local (standalone) installation
+OSSEC_TYPE?= local
-MAINTAINER= dominik.lisiak@bemsoft.pl
-COMMENT= Security tool to monitor and check logs and intrusions
+.include "${.CURDIR}/../ossec-hids/version.mk"
-LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= compiler gmake ssl
-OSSEC_TYPE?= local
-
.if ${OSSEC_TYPE} == local
CONFLICTS_INSTALL= ossec-hids-client-* \
ossec-hids-agent-* \
diff --git a/security/ossec-hids-server/Makefile b/security/ossec-hids-server/Makefile
index b10e12b..1d1003f 100644
--- a/security/ossec-hids-server/Makefile
+++ b/security/ossec-hids-server/Makefile
@@ -1,5 +1,6 @@
# $FreeBSD: head/security/ossec-hids-server/Makefile 484537 2018-11-09 18:52:21Z swills $
+COMMENT= Security tool to monitor and check logs and intrusions - server installation
OSSEC_TYPE= server
MASTERDIR= ${.CURDIR}/../ossec-hids-local
diff --git a/security/ossec-hids/Makefile b/security/ossec-hids/Makefile
index b53092a..de9ceb4 100644
--- a/security/ossec-hids/Makefile
+++ b/security/ossec-hids/Makefile
@@ -1,14 +1,6 @@
# $FreeBSD: head/security/ossec-hids/Makefile 503254 2019-06-01 19:39:09Z pi $
-PORTNAME= ossec-hids
-PORTVERSION= 3.3.0
-PORTREVISION= 0
-CATEGORIES= security
-
-MAINTAINER= dominik.lisiak@bemsoft.pl
-COMMENT= Security tool to monitor and check logs and intrusions
-
-LICENSE= GPLv2
+.include "${.CURDIR}/version.mk"
RUN_DEPENDS= ossec-hids-${OSSEC_TYPE}>=${PORTVERSION}:security/ossec-hids-${OSSEC_TYPE}
diff --git a/security/ossec-hids/version.mk b/security/ossec-hids/version.mk
new file mode 100644
index 0000000..8d989d1
--- /dev/null
+++ b/security/ossec-hids/version.mk
@@ -0,0 +1,9 @@
+PORTNAME= ossec-hids
+PORTVERSION= 3.3.0
+PORTREVISION?= 1
+CATEGORIES= security
+
+MAINTAINER= dominik.lisiak@bemsoft.pl
+COMMENT?= Security tool to monitor and check logs and intrusions
+
+LICENSE= GPLv2