summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominik Lisiak <dominik.lisiak@bemsoft.pl>2022-01-17 06:47:48 +0100
committerDominik Lisiak <dominik.lisiak@bemsoft.pl>2022-01-17 06:47:48 +0100
commit6bc9b2f46397d42c84c88f993220f79e3ff377f8 (patch)
tree1c53004f770759918ea4c4f2844b4b64ded766e1
parentUpgraded distinfo. (diff)
downloadnapi-6bc9b2f46397d42c84c88f993220f79e3ff377f8.tar.xz
Merged committter changes.2.0.1
-rw-r--r--polish/napi/Makefile37
1 files changed, 20 insertions, 17 deletions
diff --git a/polish/napi/Makefile b/polish/napi/Makefile
index 78cefa6..e6db024 100644
--- a/polish/napi/Makefile
+++ b/polish/napi/Makefile
@@ -1,5 +1,3 @@
-# $FreeBSD$
-
PORTNAME= napi
PORTVERSION= 2.0.1
CATEGORIES= polish multimedia
@@ -9,9 +7,12 @@ COMMENT= Command line subtitles downloader for napiprojekt.pl
LICENSE= GPLv3
-RUN_DEPENDS= bash:shells/bash base64:converters/base64 wget:ftp/wget 7z:archivers/p7zip mediainfo:multimedia/mediainfo
+RUN_DEPENDS= 7z:archivers/p7zip \
+ base64:converters/base64 \
+ bash:shells/bash \
+ mediainfo:multimedia/mediainfo \
+ wget:ftp/wget
-NO_ARCH= yes
USES= cmake shebangfix
USE_GITLAB= yes
@@ -19,33 +20,35 @@ GL_ACCOUNT= hesperos
GL_PROJECT= ${PORTNAME}
GL_COMMIT= ac404649571e470bf9494f788bd8a74843956851
-STRIP=
SHEBANG_GLOB= *.sh *.sh.in
-OPTIONS_DEFINE= SUBRIP UTF8 RMORIG COVER NFO
+STRIP=
+NO_ARCH= yes
+
+OPTIONS_DEFINE= COVER NFO RMORIG SUBRIP UTF8
-SUBRIP_DESC= Convert subtitles to SubRip (.srt) by default (-f subrip)
-UTF8_DESC= Convert subtitles to UTF-8 by default (-C UTF-8)
-RMORIG_DESC= Always remove intermediate files (-d)
COVER_DESC= Always try to download cover (-c)
NFO_DESC= Always try to download .nfo file (-n)
+RMORIG_DESC= Always remove intermediate files (-d)
+SUBRIP_DESC= Convert subtitles to SubRip (.srt) by default (-f subrip)
+UTF8_DESC= Convert subtitles to UTF-8 by default (-C UTF-8)
NAPI_CONF= libs/libnapi_sysconf.sh
-post-patch-SUBRIP-on:
- @${REINPLACE_CMD} -e 's|\(napiprojekt\.subtitles\.format\)=default|\1=subrip|' ${WRKSRC}/${NAPI_CONF}
+post-patch-COVER-on:
+ @${REINPLACE_CMD} -e 's|\(napiprojekt\.cover\.download\)=0|\1=1|' ${WRKSRC}/${NAPI_CONF}
-post-patch-UTF8-on:
- @${REINPLACE_CMD} -e 's|\(napiprojekt\.subtitles\.encoding\)=default|\1=UTF-8|' ${WRKSRC}/${NAPI_CONF}
+post-patch-NFO-on:
+ @${REINPLACE_CMD} -e 's|\(napiprojekt\.nfo\.download\)=0|\1=1|' ${WRKSRC}/${NAPI_CONF}
post-patch-RMORIG-on:
@${REINPLACE_CMD} -e 's|\(napiprojekt\.subtitles\.orig\.delete\)=0|\1=1|' ${WRKSRC}/${NAPI_CONF}
-post-patch-COVER-on:
- @${REINPLACE_CMD} -e 's|\(napiprojekt\.cover\.download\)=0|\1=1|' ${WRKSRC}/${NAPI_CONF}
+post-patch-SUBRIP-on:
+ @${REINPLACE_CMD} -e 's|\(napiprojekt\.subtitles\.format\)=default|\1=subrip|' ${WRKSRC}/${NAPI_CONF}
-post-patch-NFO-on:
- @${REINPLACE_CMD} -e 's|\(napiprojekt\.nfo\.download\)=0|\1=1|' ${WRKSRC}/${NAPI_CONF}
+post-patch-UTF8-on:
+ @${REINPLACE_CMD} -e 's|\(napiprojekt\.subtitles\.encoding\)=default|\1=UTF-8|' ${WRKSRC}/${NAPI_CONF}
post-install:
@${RM} -r ${STAGEDIR}${LOCALBASE}/lib/napi/*.in